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TRACE32 as TCF Agent

Version 06-Jun-2024

Introduction

The Target Communication Framework (TCF) is a vendor-neutral lightweight network protocol mainly for
communication with embedded systems (http://wiki.eclipse.org/TCF).

TRACE32 PowerView can be configured as a TCF agent. This TCF interface is useful to access the debug
functionality of TRACE32 from within an Eclipse-based interface. Simultaneous usage of TRACE32
PowerView and Eclipse is also possible.

The TRACE32 TCF integration supports the following debugging features:

Run control (Go, Break, Step,...)

Software and on-chip breakpoints

Register view

Expressions view

Memory view

Display of the source code and the disassembly (mixed mode) for the selected context
Stack trace

Display of the operating system tasks in the Eclipse Debug view.
Function sample-based profiling

Debug Symbol Browser for the Wind River Workbench
Multi-core debug in AMP and SMP

The TRACES32 TCF integration also provides a synchronization between TRACE32 PowerView and Eclipse.
For example, setting a breakpoint or executing a single step at the TRACES32 side will be reported to Eclipse
and vice versa.

NOTE: The TRACE32 TCF integration is available for all architectures and compilers

supported by TRACE32.

NOTE: The debug symbols have to be loaded in TRACE32 PowerView and do not

need to be loaded in Eclipse.
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Restrictions

This solution is not a full integration of TRACE32 in the described IDEs. Not all features of TRACE32
PowerView are available in Eclipse or Wind River® Workbench. This solution should be only be used for
debugging bare-metal applications or simple operating systems as FreeRTOS.

The following features are for instance not supported by this solution:

J Peripheral views, MMU and Cache views
. Memory access classes. The memory view in Eclipse only shows the current context.
. Trace

. MMU and Cache views
. OS Awareness

J Hypervisor debugging
. FLASH programming

Please contact support@lauterbach.com for more information.

Documentation Updates

The latest version of this document is available for download from:
www.lauterbach.com/pdf/app_tcf_setup.pdf

Related Documents and Tutorials

o For information about how to install TRACE32, see “TRACE32 Installation Guide”
(installation.pdf).

. For a video tutorial about TRACE32 as a TCF agent for Wind River Workbench, visit:
support.lauterbach.com/kb/articles/demo-of-the-trace32-integration-to-the-wind-river-
workbench

. For a video tutorial about TRACE32 as a TCF agent for Eclipse, visit:
support.lauterbach.com/kb/articles/demo-of-the-trace32-integration-to-eclipse

©1989-2024 Lauterbach TRACE32as TCF Agent | 5


http://www.lauterbach.com/pdf/app_tcf_setup.pdf
https://support.lauterbach.com/kb/articles/demo-of-the-trace32-integration-to-the-wind-river-workbench
https://support.lauterbach.com/kb/articles/demo-of-the-trace32-integration-to-the-wind-river-workbench
https://support.lauterbach.com/kb/articles/demo-of-the-trace32-integration-to-eclipse

Initial Setup and Requirements

In this chapter:
. TRACE32

. Eclipse: If you want to integrate TRACE32 with Eclipse, then skip the Wind River Workbench
section in this document.

. Wind River Workbench:

- If you want to integrate TRACE32 with Wind River Workbench, then you have to take the
additional steps described in section “Wind River Workbench”.

- After that, continue with section “TRACE32 Setup”, page 14

J Synopsys MetaWare IDE: If you want to integrate TRACE32 with the MetaWare IDE (a special
version of Eclipse)

TRACE32

For information about how to install TRACE32 under MS Windows, see “MS Windows” in TRACE32
Installation Guide, page 21 (installation.pdf). We recommend that you install TRACE32 on the system
path suggested by the installer: C:\T32.

For information about how to install TRACE32 under Linux, see “PC_LINUX” in TRACE32 Installation
Guide, page 23 (installation.pdf).

A TRACES2 version from February 2016 or later is required. If the TRACES32 version is too old, then you
will get an error box with the message “TCF=(illegal command”)” when trying to start TRACE32
PowerView as a TCF agent.

. To check the TRACES2 version, choose Help menu > About TRACE32.

For a description of how to configure and start TRACES32 as a TCF agent, see “TRACE32 Setup”, page 14.
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Eclipse

According to the Eclipse TCF documentation, the following components are required:
. JDK 1.8.0 or later

. Eclipse SDK 3.8 or later

J CDT (C/C++ Development Tools) SDK 8.1 or later

For more information about the minimal required setup, please refer to the TCF Wiki page
(http://wiki.eclipse.org/TCF).

NOTE: For Eclipse 3.7 (Indigo) and 3.6 (Helios) you need to install the “Target
Communication Framework (Incubation)” plug-in from
http://download.eclipse.org/tools/cdt/releases/indigo.
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To install the TCF C/C++ Debugger in Eclipse (3.8 or newer):
1. Choose Help menu > Install New Software.

2. From the Work with list, select -- All Available Sites -- or select an update site for your Eclipse
version under http://www.eclipse.org/tcf/downloads.php.

3. Type “TCF” in the search field.
You may have to wait for the list to be populated.

4, Select the TCF C/C++ Debugger.

= Install | (S e S
Available Software

Check the items that you wish to install. Di
Work with:  --All Available Sites-- - Add...

Find more software by working with the "Available Software Sites” preferences.

TCF
MName Version i
[] 4+ C/C++ Remote (over TCF/TE) Run/Debug Launcher 1.2.0.201405271222
[7] 4 TCF Terminal (Console) View 1.2.0.201406042322
4 (00 Mobile and Device Development
[] 4+ C/C++ Remote (over TCF/TE) Run/Debug Launcher 1.2.0.201405271222 E
L TCF C/C++ Debugger 1.2.0.201405271222
[] 4+ TCF Remote System Explorer add-in 1.2.0.201405271224
[7] L TCF Target Explorer 1.2.0.201405271222
[7] 4 TCF Terminal (Console) View 1.2.0.201406042322 2
[ Selectall || Deselectall 1 item selected
Details
Afull-featured C/C++ debugger for local or remote systems running a TCF agent.TCF is an extensible, lightweight protocol for universal target access. b
More...
Show only the latest versions of available software Hide items that are already installed
Group items by category What is already installed?

[] Show only software applicable to target environment
Contact all update sites during install to find required software

@ < Back Next > Fnih
E

5. Click the various Next buttons and follow the instructions of the install wizard to finish the
installation.

6. Restart Eclipse.
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Wind River Workbench

NOTE: For the Wind River Workbench 3.3, you need to install the “Target Communication
Framework (Incubation)” plug-in from
http://download.eclipse.org/tools/cdt/releases/indigo.

The On Chip Debug (OCD) version of the Workbench is not supported by this
integration.

You need to enable the TCF C/C++ Debugger in the Wind River Workbench.
1. Choose Windows menu > Preferences.
2. In the Preferences dialog, click Wind River > Capabilities.

3. Select the check box TCF C/C++ Debugger.

Preferences L@éj
type filter text Capabilities fe=10 4 r v
- G |
enera [¥] Prompt when enabling capabilities
s CfC++
. Help Capabilities:
> Install/Update ) 2 Development
> Remote Development P
RSS/Atom Feed View £ TCF C/C++ Debugger I
> Run/Debug IR
> Target Explorer . 3 Terminal
> Team
> Terminal
Validation [ Enablean || DisableAl
4 Wind River o
> Build Console Pailan:
> Build Properties Use the C/C++ debugger to debug systems running a TCF agent. -
Capabilities
FTP/TFTP Server
Host Tools Execution L
> XML
’Restore Defaults] ’ Apply ]
I:?} [ oK ] ’ Cancel ]
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Moreover, you need to disable the launch configuration filter for the Target Communication Framework.

1. Choose Windows menu > Preferences

2. In the Preferences dialog, click Run/Debug > Launching > Launch Configurations.

3. Clear the check box Target Communication Framework.

Preferences

type filter text

> General

s CfC++

> Help

> Install/Update

> Remote Development
R55/Atom Feed View
Run/Debug

Breakpoint Relocation

[

Breakpoints
Console
External Tools
4 Launching
Default Launchers
Launch Cenfigurations
Perspectives
String Substitution
Target Communication
View Management
View Performance
> Target Explorer
> Team
> Terminal
Validation
> Wind River
> XML

@

Launch Configurations

Launch Cenfiguration Filters

Filter configurations in closed projects

Filter configurations in deleted or missing projects
[] Apply window working set{s)

Filter checked launch configuration types:

[[] [E]c/c++ Application

[[] [E]c/C++ Attach to Application
[[] [E]€/C++ Postmortem Debugger
[[] [E]c/C++ Remote Application
@ Launch Group

%Program

[EL Remote Application

=1 e L~

I [ [ETarget Communication Framework I

m

[] Delete configurations when associated resource is deleted

Migration

Search for, select, and upgrade launch configurations to be compatible with current

tooling.

’ Restore Defaults] ’ Apply ]

[

ok || Cancel |
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Synopsys MetaWare IDE

The MetaWare IDE is based on Eclipse. Thus you can basically you can use TCF the same way than

described for native Eclipse before.

Please note that the MetaWare IDE contains proprietary changes to Eclipse. As a result Lauterbach can’t

ensure that controlling TRACES32 via TCF is fully functional. Thus it is recommended to use native Eclipse.

To install the TCF C/C++ Debugger in Synopsys MetaWare IDE:

1. Choose Help menu > About MetaWare IDE > Installation Details > Features

2. Check the version number of the Eclipse Platform. This is the Eclipse version on which you copy
of MetaWare IDE is based on. You must have version 4.2 or higher.

MetaWare IDE based on Eclipse Platform| Comment
L-2016.06 10.3 Eclipse 4.4 (Luna) TCF successfully tested
L-2016.03 10.2 Eclipse 4.4 (Luna)

K-2015.12 10.1 Eclipse 4.4 (Luna)

K-2015.09 10.0 Eclipse 4.4 (Luna)

J-2015.03 9.8 Eclipse 4.4 (Luna)

J-2014.12 9.7 Eclipse 4.4 (Luna)

J-2014.06-SP1 9.6 Eclipse 4.4 (Luna)

J-2014.06 9.5 Eclipse 4.3 (Kepler

1-2013.12.1 9.4 Eclipse 4.3 (Kepler)

1-2013.12 9.3 Eclipse 4.3 (Kepler)

3. Choose Help menu > Install New Software...
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4. In dialog windows “Install” add the in the Work with box the update site according to the version
of the Eclipse platform you got before.

Eclipse Platform Update Site (p2 Repository)

Eclipse 4.14 (2019-12) http://download.eclipse.org/releases/2019-12
Eclipse 4.13 (2019-09) http://download.eclipse.org/releases/2019-09
Eclipse 4.12 (2019-06) http://download.eclipse.org/releases/2019-06
Eclipse 4.11 (2019-03) http://download.eclipse.org/releases/2019-03
Eclipse 4.10 (2018-12) http://download.eclipse.org/releases/2018-12
Eclipse 4.9 (2018-09) http://download.eclipse.org/releases/2018-09
Eclipse 4.8 (Photon) http://download.eclipse.org/releases/photon
Eclipse 4.7 (Oxygen) http://download.eclipse.org/releases/oxygen
Eclipse 4.6 (Neon) http://download.eclipse.org/releases/neon
Eclipse 4.5 (Mars) http://download.eclipse.org/releases/mars
Eclipse 4.4 (Luna) http://download.eclipse.org/releases/luna
Eclipse 4.3 (Kepler) http://download.eclipse.org/releases/kepler

You can get a full list of all “p2 Repositories” at https://wiki.eclipse.org/Simultaneous_Release
5. Type “TCF” in the search field. (You may have to wait for the list to be populated.)
6. Select the TCF C/C++ Debugger.

7. Click on Next and follow the dialogs, which guide you through the installation process.

It's recommended to install the TRACE32 TCF Eclipse Plug-In as described below.
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The MetaWare IDE uses several special proprietary views (child windows) when it is connected to a
MetaWare (or SeeCode) debugger. When using TCF you have to use the native Eclipse debug views.
To get the right views used Window menu > Show View ( > Other...)

Data to display MetaWare view Native Eclipse View TRACE32 Command
Core Register Register (CDI) Register Register.view
Breakpoints Breakpoints (MetaWare)* Breakpoints Break.List
Watchpoints Watchpoints Breakpoints Break.List
Disassembled Code  |Disassembly (MetaWare) Disassembly List.Mix

Raw Memory Memory (MetaWare)* Memory Var.DUMP

Local Variables Locals* Variables Var.Local

Global Variables Global Variables* Expressions Var.Watch

HLL Expressions Expressions (MetaWare)* Expressions Var.Watch

Call Stack Call Stack* Debug Frame.view

ELF Sections Modules (MetaWare) Modules sYmbol.List.SECtion
Auxiliary Register Auxiliary register N/A Data.dump AUX:0
Hierarchic Symbol Executable sYmbol.Browse
Tree

(* If marked with * you

can also use the native Eclipse view instead.)

Don’t mix up the Target Communication Framework (TCF) with the ARC target
configuration files (TCF files). Both have nothing in commen except theire
abbreviation.
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TRACE32 Setup

Installing the TRACE32 TCF Eclipse Plug-In

Lauterbach offers an Eclipse plug-in with a simplified and adapted launch configuration. Using this plug-in,

you can configure and start TRACE32 from within Eclipse or the Wind River Workbench.

To install the TRACE32 TCF Eclipse plug-in:

1.

2
3.
4

Choose Help menu > Install New Software.
In the Work with box, type the update site: https://www.lauterbach.com/eclipse/tcf
Press Enter.

Make the selection shown below.

= Install 3
Available Software
1
—

Check the items that you wish to install.

Work with:  http://www.lauterbach.com/eclipse/tef - Add... || Manage... |

type filter text

Mame Wersion

V| 000 Lauterbach TRACE32 TCF connection
7] Lk Lauterbach TRACE32 TCF connection L27

Select All | | Deselect All 1 item selected

Details

| Show only the latest versions of available software V| Hide items that are already installed
V| Group items by category What is already installed?
Show only software applicable to target environment

V| Contact all update sites during install to find required software

Click the various Next buttons and follow the instructions of the install wizard to finish the
installation.

Restart Eclipse.
Choose Run menu > Debug Configurations.

You should now have the TRACE32 TCF configuration in the Debug Configurations window, as
shown below.
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& Debug Configurations

Create, manage, and run configurations

Connect to Lauterbach TRACE32 aver the Target Communication Framewark

| = - Canfigure launch settings from this dialog:
type filter text - Press the 'MNew’ button to create a configuration of the selected type.

[E] C/C++ Application

[E] C/C++ Attach to Application
[E] C/C++ Postmortem Debugger
[E] C/C++ Remate Application
R Launch Group

= Launch Group (Deprecated)

| o= e -

- Press the 'Duplicate’ button to copy the selected configuration.

- Press the 'Delete’ button to remave the selected configuration.

o

- Press the 'Filter’ button to configure filtering options.
- Edit or view an existing configuration by selecting it.

= cation Frame
JA TRACE32 TCF Configure launch perspective settings from the 'Perspectives’ preference page.

4 | i b

Filter matched § of & itemns

8. Double-click TRACE32 TCF to access the new TRACE32 tab.

9. On the TRACE32 tab, choose one of the following configuration methods:

Option A If you have not worked with TRACES32 before, we recommend that you
configure the different TRACES32 settings in the Eclipse plug-in by selecting
the Manual configuration option.

See “Option A: Manual Configuration”, page 16.

Option B If you already have a working TRACE32 configuration, we recommend that
you specify the TRACE32 executable and the configuration file directly by
selecting the Select executable and configuration file option.

See “Option B: Select Executable and Configuration File”, page 21.
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Option A: Manual Configuration

3.

If you want to configure the TRACES32 options manually, select Manual configuration from the

TRACE32 configuration drop-down list in Eclipse.

The fields for a manual configuration are will be displayed on the TRACE32 tab.

Make your settings.

- For a description of the fields on the TRACE32 tab, see tables below.

- Atemporary configuration file will be created in the default temporary directory when

TRACES32 is started.

- For examples of the connection types USB and Ethernet, click here.

= Debug Configurations

Create, manage, and run configurations

Connect to Lauterbach TRACE32 over the Target Communication Framewaork

- B
= x‘ = Mame: MNew_configuration

type filter text i Target |y Download =4 Symbol Files | & Path Map E Source [[C] Commen ‘TRACBZ

[T] C/C++ Application

[T] C/C++ Attach to Applic: TRACE32 configuraticji: [Manual configuration

[T] C/C++ Postmort

Parameters to launcl
[E] C/C++ Remote £ fr—

i Launch Group Device: [Debugger ']
= Launch Group (Deprecal
[E Target Communication Connection Type: [USB v]
4 Jjh TRACE2TCF MNede name / IP Address:
A New_configuration
Architecture: [ARM V]
Paths:

Waorking path:

System path:

Interfaces:

|| TCF Discovery  Portvalue: 1534

[C] TRACE32 AP Port value: | 20000

Display:

Title: TRACE32 PowerView For ARM
[ Run TRACE32 PowerView in background

oRcRoRo

Start-up Script:

Source: [File ']
Parameters:

@ [7] Automatically start TRACE32 with the debug configuration (TCF port number must be specified)
Target ID:

Delay starting TCF (s):

4 [ [ r

Filter matched 9 of 9 iterns

G
@

Browse...

Revert ] [ Apply

]

[

Debug ] [ Clase

Click Apply when you are done.

You are now ready to start TRACE32 as described in “Start TRACE32”, page 24.
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[A] Parameters to launch TRACE32

Device

Select if you are using a JTAG Debugger or a TRACE32 Instruction Set
Simulator.

Connection Type

For a JTAG Debugger, select if you have a USB or Ethernet connection to
the Lauterbach debugger hardware.

Node Name / IP
Address

For USB connection, optionally set the name of the connected device.
This option is useful if multiple Lauterbach debuggers are connected per
USB to one PC.

For Ethernet connection, set the IP address or the host name of the
used Lauterbach debugger hardware.

Architecture

From the drop-down list, select the used target architecture (e.g. Arm,
TriCore...).

[B] Paths

Working Path

Active directory after starting the TRACE32 instance.

System Path

Directory where the executable and system files of TRACE32 are located
(e.g. C:\T32).

If you have observed our recommendation and installed TRACE32 on the
system path suggested by the installer, you can ignore the step-by-step
procedure below.

To determine the system path of a particular TRACE32 installation:

1. Start TRACE32.

2. Type at the TRACE32 command line:

PRINT OS.PresentSystemDirectory ()

[C] Interfaces

;the message line below the TRACE32 command line
;displays the system path of this particular
; TRACE32 installation

TCF Discovery

Enable/disable the TCF discovery. If the discovery is disabled, a TCF port
number must be specified (default: 1534).

The TCF discovery is a mechanism where agents advertise their peers by
sending UDP packets to other agents.

TRACES32 API

Enable/disable the TRACE32 Remote API

©1989-2024 Lauterbach
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[D] Display

Title Set the window title of the TRACES32 instance. The title will be displayed in
the Name column under Available Targets if the TCF discovery is
enabled.

Run TRACES32 Start TRACE32 PowerView without a graphical user interface. TRACES32

PowerView in can be terminated using the Eclipse Terminate button.

background

[E] Start-up Script

Source

When a TRACES32 instance starts, the PRACTICE script autostart.cmm is

executed, which then calls the following scripts:

. system-settings.cmm (from the TRACE32 system directory, usu-
ally C:\t32)

. user-settings.cmm (from the user settings directory: on Windows
%APPDATA%\TRACE32 or ~/.trace32 otherwise)

. work-settings.cmm (from the current working directory)

In the TRACE32 TCF plug-in you can specify an additional PRACTICE
script which is automatically started afterwards.

The TRACE32 TCF plug-in supports two types of start-up scripts:

. File

. Built-in Script

When Source is set to File, the script assigned to the File item will be
executed.

File

If Source is set to File, specify the start-up script (*.cmm) here.

Parameters

Set the parameters that are passed to the start-up script (*.cmm) from
File.

Built-in Script

The start-up script can be edited and stored directly.

[F] Start TRACE32 with the debug configuration

Target ID This option can be used only if TCF discovery is disabled.
A new target with a specific port must be declared first (see Manual
Debug Target Setup). The new “Target ID” should be then written into this
box.

Delay An optional delay time until TRACE32 completes its start-up.

NOTE: The TRACES32 TCF plug-in automatically creates a TRACE32 configuration file

when you start TRACES32 from within Eclipse.
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Example of the Connection Type USB

”
& Debug Configurations

Create, manage, and run configurations

Connectto Lauterbach TRACE32 over the Target Communication Framewark

SR IEE

| type filter text

C/C++ Application
C/C++ Attach to Application
C/C++ Postrmortem Debugger
C/C++ Remote Application

@ Launch Group

[ Launch Group (Deprecated)

IE Target Communication Framework
4 jk TRACE32 TCF
7k Manual_config_Ethernet
J/k Manual_config_USB

Filter matched 10 of 10 iterns

Name: Manual_config_USB

B8 Target ﬁﬁn Downlead (-:* Symbel Files (,,% Path Map FE/ Source (E Commen fA TRACE32

TRACE32 configuration: [ Manual configuration

+ | [ stert TRACER: |

Parameters to launch TRACE32

Nevice: [Dehunnpr

Cennection Type: use

Node name / IP Address:

Architecture: [ARM

Paths:

Working path:  c\t32

System path:  e\32

Interfaces:

TCF Discovery  Port value: | 1534

TRACE32 API  Portvalue: | 20000

Display:

Title: TRACE32 PowerView For ARM
Run TRACE32 PowerView in background

Start-up Script:

["] Automatically start TRACE32 with the debug configuration (TCF port number must be specified)

Source: l File b ]
File: CAT32\demo\arm\hardware\omapddied pandaboardiminitdemo_sieve_sar-ram.cmm
Parameters:

Browse...

Target ID: |

Delay starting TCF (s): |

[ Revert

] I Apply

]

@

Debug Clase

||

I
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Example of the Connection Type Ethernet

’
£ Debug Configurations

Create, manage, and run configurations

Cannect to Lauterbach TRACE32 over the Target Cammunication Framework

CEX| B3

Name:  Manual_config_Ethernet

| type filter text 28 Target (“3[] Download (_=+ Symbol Files (‘?ﬁ Path Map (E:/ Source rﬁ Common rA TRACE32
[£] C/C++ Application
[E] C/C++ Attach to Application TRACE32 configuration: [Manuai configuration '] lA Start TRACE32 I
[E] G/Cr+ Postmortem Petfugger Parameters to launch TRACE32
[€] C/C++ Remote Application
i Launch Group Device: [Dehnnnel ']
= Launch Group (Deprecated) 1

EE Target Communication Framework ol e Etbeipel I T

4 jh TRACE32 TCF
A Manual_cenfig_Ethernet

Nede name /IP Address: pod0.example.com

/A Manual_config_USE Architecture: [TIICOIC ']
Paths:
Working path: Browse..
System path: Browse..
Interfaces:

TCF Discovery  Port value: | 1534

I TRACES2 API  Port value: | 20000

Display:

Title: TRACE32 PowerView For TriCore
[ Run TRACE32 PowerView in background

Start-up Script:

Source: [ File - ]
File: CA\T3N\demo'tricore\hardware\triboard-te2:84tc275t\tc275t_demo.cmm Browse...
Parameters:

[7] Automatically start TRACE32 with the debug configuration (TCF port number must be specified)

Target ID: | |

Delay starting TCF (s): | |

Filter matched 10 of 10 items | Revet || Apply |

@

t————

I Debug I [ Close ]
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Option B: Select Executable and Configuration File

You can, instead of configuring the TRACES32 parameters manually, directly set the path to the TRACE32
executable and configuration file.

1. From the TRACE32 configuration drop-down list, Select Executable and configuration file.
The fields for a direct configuration are will be displayed on the TRACE32 tab.
2. Make your settings.

For a description of the fields on the TRACE32 tab, see tables below.

& Debug Configurations

Create, manage, and run configurations

Connect to Lauterbach TRACE32 over the Target Communication Framework

= *| =3 Name: New_configuration

type filter text i Target ) Download | 53 Symbol Files | & Path Map % Source | ] Common | i TRACES2
[©] C/C++ Application
(2] C/C++ Attach to Applicatic TRACE32 configuratior iSeIect executable and configuration file

[E] C/Cs+ Postmortem Parameters to launch TRACE32
[€] C/C++ Remote Appl

£ Launch Group TRACE32 executable: CAT32\bin\windows64\t32marm.exe
[ Launch Group (Deprecated’

EE Target Communication Fra

+ /A TRACE2 TCF T CATI\config 32

/& Mew_configuration

A

N /A start TRACES? |

Configuration file Parameters:

Startup script: C:\T32\demo\arm'compiler\gnu\demo_sram.crnm

Script Parameters:

Working path: C:\T32\demo\arm\compiler\gnu| Browse...

[T Automatically start TRACE32 with the debug configuration (TCF port number must be specified)
Target ID:

Delay starting TCF (s):

Command line: C\T32\dero\arm\compilerignu: CAT32\bin\windows64\t32marm.exe -c C\T32\config.32 -s CAT32\demo\arm

[ Start TRACE32 PowerView on remote host over Telnet or SSH. (The config file should contain SCREEN=0FF)

oo k
Filter matched 9 of 9 items ’ Beverd ] ’ Apply ]
@' [ Debug ] ’ Close ]

3. Click Apply when you are done.
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[A] Parameters to launch TRACE32

TRACE32 executable Used TRACE32 executable e.g.
C:\T32\bin\windows64\t32marm.exe

Configuration file Used TRACES2 configuration file e.g. C:\T32\config.t32.

Configuration file parameters Parameters for the configuration file

Start-up script When a TRACES2 instance starts, the PRACTICE script
autostart.cmm is executed, which then calls the following
scripts:

J system-settings.cmm (from the TRACE32 system
directory, usually C:\t32)

. user-settings.cmm (from the user settings directory:
on Windows %APPDATA%\TRACE32 or ~/.trace32
otherwise)

. work-settings.cmm (from the current working direc-
tory)

Here you can specify an additional PRACTICE script which
is automatically started afterwards.

Script parameters Parameters for the start-up script file

Working path Active directory after starting the TRACE32 instance.

[B] Start TRACE32 with the debug configuration

Target ID This option can be used only if TCF discovery in disabled.
A new target with a specific port must be declared first (see Manual
Debug Target Setup), then its “Target ID” should be written into this box.

Delay An optional delay time until TRACE32 complete its startup.

[C] Start TRACE32 on remote host

When checked, TRACE32 PowerView will be open in a remote machine using Telnet or SSH protocol.

The parameters specified in [A] should exists in the remote machine.
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Enable TCF Agent

To configure TRACES32 as a TCF agent, use the command SETUP.APL.TCF.ON.

SETUP.API.TCF.ON ; enable TCF agent in TRACE32

Optionally, you can specify a TCF port number using the command SETUP.APL.TCF.PORT. Note that using
a fixed port number disables the TCF discovery mechanism. Consequently, the TCF front-end (Eclipse)
must connect to TRACES32 using the specified port number. This process is detailed later in this document.
Settings the port number must be done before enabling the TCF agent using SETUP.APL.TCF.ON. ettings
the port number to 0 re-enables the TCF discovery mechanism.

SETUP.API.TCF.PORT 1234 ; use 1234 as TCF port
SETUP.API.TCF.ON ; enable TCF agent

7
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Establish a Debug Session

Start TRACE32

To start TRACE32 from within Eclipse:

1. Choose Run menu > Debug Configurations.
2. In the left window pane of the Debug Configurations window, click a configuration under the
entry TRACE32 TCF.

’
£ Debug Configurations

Create, manage, and run configurations

Connect to Lauterbach TRACE32 over the Target Communication Framewark

X B

MName:  Mew_cenfiguration

type filter text

[E] C/C++ Application
[2] C/C++ Attach to Applicatic TRACE32 configuration: | Select executable and configuration file
[€] C/C++ Postmortem Debug
[E] ¢/C++ Remote Application
L Launch Group

) TRACE32 executable: CAT32\bin\windows64\t32marm.exe
@ Launch Group (Deprecated

i Target | ) Download | 55 Symbol Files | & Path Map & Source |[C] Commuf | jk TRACES2

A

| /A Start TRACES? |

Parameters to launch TRACE32

= -

:1: TRP:CBE TcF Configuration file: CAT32\configt32
/& New_configuration

Configuration file Parameters:

Startup script: CA\T32\demo'arm'.compiler\gnu\dema_sram.cmm

Script Parameters:

Working path: CAT32\dema\arm\compiler\gnu| Browse...

[7] Automatically start TRACE32 with the debug configuration (TCF port number must be specified)

Target 1D:

Delay starting TCF (s):

Command line: CAT32\demo\arm\compiler\gnu: CAT32\bin\windows64\t32marm.exe -c C\T32\configt32 -s C\T32\demao\arm

[7] Start TRACE32 PowerView on remote host over Telnet or S5H. (The config file should contain SCREEN=0FF)

1 3
Filter matched 9 of 9 items ’ feverl ] [ Apply ]
@) [ Debug l ’ Close ]

3. Click the TRACE32 tab.
4. Click the Start TRACE32 button.

After starting, TRACES32 executes the PRACTICE start-up script (*.cmm) you have specified.
5. Have you specified a fixed TCF port number in the TRACES32 configuration file?

- No: Please continue with section TCF Discovery.
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- Yes: Please continue with section Manual Debug Target Setup.

NOTE:

The TRACE32 TCF Eclipse plug-in also adds a new button to the tool bar with
the Lauterbach logo to start TRACE32.

= eclipse-workspace - Eclipse

File Edit Source Refactor mmmmmss'e Search Project Run  TRACE32Z Window Help
3 wifS2 TR~ Eradr-@g-i@-igint IS TR - W

If this button is not displayed in the tool bar, take these steps:

. Choose Windows menu > Perspective > Customize Perspective.

. On the Tool Bar Visibility tab, select the check box Lauterbach TRACE32.
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TCF Discovery

To establish a debug connection using the TCF discovery:

1.

2.

In the Debug Configurations dialog, click Target Communication Framework.

2 Debug Configurations

wTw TR &

Create,

ge, and run config

Run or debug a program using Target Communication Framework

EIEEN

Name: New_configuration

Target

[] C/C++ Application
C/C++ Attach to Application
PP

[€] C/C++ Postmortem Debugger

C/C++ Remote Application
pp

4 i Target Communication Framework
8 New_configuration

["] Run TCF symbols server on the local host

[] Run instance of TCF agent on the local host

[] Use local host as the target

Filter matched 7 of 7 items

o)

Target

TargetID: TCP:127.00.1:54056
ilable targets: E
Name

=8 TRACE32 PowerView for ARMG4 Windows 7

05 User

kimal

Transp... Host Port
TCP 127001

i

[c]

Peer ID: [TCP:127.0.0.1:55529

Peer name:  TRACE32 PowerView for ARMG4 0 [Power Debug II @ 192.168.187.43]

Peer properties:

55529

D Download | pi Application | &)= Arguments| B Environment| 55 Symbol Files| & Path Map| 1 Source | [C] Commen

Edit...

Remove
Revert Apph

m

MName

@ AgentlD

® Host

® 05Mame

® port

® SenviceManagerlD
® TRACE32 Hardware
® TRACE32 Version
® Target Architecture
® Transporthame

® UserMame

Value

S6eadl cd-bfb6-4a93-870e-2d762...

127001
Windows 7
55529

S6eadl cd-bfb6-4a93-870e-2d762...

PowerDebug-II
5.2016.03.000071216MXD
ARMG4

TCP

kjrnal

Remove

A See Step 2. below.

B If the TCF discovery has been enabled in TRACE32, then you should see the TRACE32

PowerView instance on the Target Tab under Available Targets.

C A double-click on the Name will show the properties of the TRACE32 PowerView instance

In case you are using the standard Target Communication Framework configuration, clear all

including the target architecture, the TRACE32 software version and the used TRACE32

hardware.

three check boxes on the Target tab:

Run TCF symbols server on the local host

Run instance of TCF agent on the local host

Use local host as the target
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3. To establish a debug connection, select the TRACE32 instance under Available Targets, and
then click the Debug button.
If the TCF discovery is enabled in TRACE32, the TCF port number will be
automatically selected. This means that a new port number could be used
each time a new TRACE32 PowerView instance is used.
4. Choose Windows menu > Perspective > Other > Debug.

< Debug? - c:\t32\demo\arm\.compiler\gnu-pic\sieve.c - Eclipse EI@
File Edit Source Refactor Mavigate Search Project Run TRACE32 Window Help
e O [CTS CTT  2 AT BH-0-GQ ' B | R C/C++ |45 Debug2 | i Debug Quick Access
%5 Debug &2 | i ¥ = B @ Breakpoints % = g
a [ﬁ MNew_configuration (TRACE32 PowerView For ARM) ®x % {%} o |, | =
a f® OMAP4430APPL (Suspended; Signal: stopped at breakpoint) & sieve.c [address: 403017e8] [type: Software]
= (4030178 [sieve_arm] main(): ..emoh\arm\compiler\gnu-picisieve.c, line 650 & sieve.c [function: sieve] [type: Software]

0:403000e0 [sieve_arm] gomain()

Mo scope specified.

crtl-pic.s [ sieve.c 82 22 Disassembly = B i Registers 3 = | & | Ched = 8
3 do { i Hex Decimal Descr.. *
if (monHook)
monHook () ; RO fFFfb96 4294966166 |
if (watchdogTrigger) "R1 48382128 1876896848 3
watchdogTrigger(); i R2 20809808C 12
R3 48382118 1876896824
mstaticl = 12;
mstatic? = 34; ikl R4 48382868 1876895848
MCoUNt+; RS Bopazade s4e8
Rb 2351dbZe 592567886
inc = (4 * 15e@@) / period; i R7 4@3600080 1876887552
sign = ( (mcount ¥ pericd) » pericd/2 ) ? -1 : +1; 5 Rg 208088081 1 il
plotl = pleotl + sign * inc; - = .
plot2 = 25888 * sign;
Hex: £Ffffb36, Dec: 4294966166, Oct: 837777775626
vtriplearray[@][@][@] = 1; Bin: 1111,1111,1111,1111,1111,1811, 1881,8118
vtriplearray[1][@][@] = 2; Size: 4 bytes, readable, writable
vtriplearray[@][1][@] = 3;
vtriplearray[@][@][1] = 4; - -
4 2 4 2
(%)= Variables i3 EE & | ef = B8
MName Type Value 'S
- | int 55 1
()= inc short 60
()= sign short 1
> W op char* 9x4838218c -
] 1 ¢
68 -
Hex: 883c, Dec: 68, Oct: 874 =
4 2
Writable Smart Insert 650:23
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Manual Debug Target Setup

If the TCF discovery has been disabled in TRACES32 by specifying a fixed TCF port number in the
configuration file, then you need to create a new target setup.

To create a new target setup:

1.

Choose Run menu > Debug Configurations dialog > Target Communication Framework to

open the Debug Configuration window.
Click the New button on the Target tab.
The TCF Debug Target Setup dialog opens.

& TCF Debug Target Setup

Select a task

Select an option that describes the task you want the wizard to perform

@ Manual setup of TCF connection properties.
_) Setup TCF agent on local host.
_) Setup TCF agent on remote host over Telnet or 55H.

©)

[==]
=
&
W

Cancel

Select Manual setup of TCF connection properties, and then click Next.

In the Peer name field, enter any name e.g. “TRACE32”

For the Port property, set the port number used by TRACE32, e.g. we use here the default port

number 1534, then press Finish.

& TCF Debug Target Setup

Manual client configuration

Peer ID: USR:1458234684800

Peer name:  TRACE32|

Peer properties:

MName Value
® Host 127.00.1
® port e 1534
® Transporthame TCP

Add

Rernove

Cancel

I

A new entry with the selected name will then appear on the Target tab under Available Targets, see

screenshot below.
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6.

7.

T TS - v = -
2 Debug Configurations e - M

Create, ge, and run ig ions B
Run or debug a program using Target Communication Framework

EIEEN

Mame:  New_configuration

type filter tet 9 Target *._“7) Download| g Application| 8= Arguments | B Environment| 53 Symbol Files| & Path Map | i Source| ] Common

[E] C/C++ Application -
[E] C/C++ Attach to Application ["] Run TCF symbols server on the local host

[E] C/C++ Postrortem Debugger ["] Run instance of TCF agent on the local host
[E] C/C++ Remote Application [CUse local host as the target
B+ Launch Group
4 [ Target Communication Framework
FE Mew_configuration Target ID: USR:1458235323136
Available targets:

Target

m

0s User Transp.. Host Port
TP 127.001 1534

o
Filter matched 7 of 7 items PRl

To establish a debug connection, select the TRACE32 instance under Available Targets, and
then click the Debug button.

Choose Windows menu > Perspective > Other > Debug.

< Debug? - c:\t32\demo\arm\.compiler\gnu-pic\sieve.c - Eclipse EI@
File Edit Source Refactor Mavigate Search Project Run TRACE32 Window Help

e B [CTS CTT  2 X JL'#'Q'%' ﬁ|%CJ’C++ 7{.‘@Debug Quick Access @

%5 Debug &2 | i ¥ = B @ Breakpoints % = g
4 [ﬁ MNew_configuration (TRACE32 PowerView For ARM) b4 % &S e | =] Zq">_lv
a f® OMAP4430APPL (Suspended; Signal: stopped at breakpoint) & sieve.c [address: 403017e8] [type: Software]
= (4030178 [sieve_arm] main(): ..emoh\arm\compiler\gnu-picisieve.c, line 650 & sieve.c [function: sieve] [type: Software]

0:403000e0 [sieve_arm] gomain()

Mo scope specified.

(5] ertd-pic.s [ sievec 52 Disassembly = O il Registers &2 E = | 2] | et = 0O
do { i MName Hex Decimal Descr.. *
if (monHook) S
monHook () ; oini RO fFffb96 4294966166 |
if (watchdogTrigger) i R1 408302128 1876896048 5
watchdogTrigger(); i R2 2000088C 12 |
. i R3 48382118 1876896024
mstaticl = 12; 1 R 483820868 1876895848
mstatic2 = 34; .
mcount++; oini RS 2e802ade 8400
i} R6 2351db2e 592567886
inc = (4 * 15888) / period; i R7 40300000 1876887552
sign = ( (mcount ¥ period) > period/2 ) ? -1 : +1; 188 RA BBBEE881 1 il
plotl = pleotl + sign * inc; O i ! s

plot2 = 25888 * sign;
A Hex: £Ffffb36, Dec: 4294966166, Oct: 837777775626

vtriplearray[@][@][@] = — | Bin:1111,1111,1111,1111,1111,10811,1661,8118

1;
vtriplearray[1][@][@] = 2; Size: 4 bytes, readable, writable
vtriplearray[@][1][@] = 3;
vtriplearray[@][@][1] = 4; - -
I » 4 »
(%)= Variables &7 = 3{;| i A
MName Type Value Il
- | int 55 1
()= inc short 68
()= sign short 1 M
> W op char* 9x4838218c -
4 1 | +
68 -
Hex: 883c, Dec: 68, Oct: 874 =
4 ¥
Writable Smart Insert 650:23
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Open Debug Perspective Automatically

To activate the Debug perspective when a program is launched, do the following:

1. Choose Windows menu > Preferences.

2. In the left window pane, click Run/Debug > Perspectives.

J Under Open the associated perspective when launching, select the Always option.
This will cause the perspective associated with a program to become active whenever it is launched.

-
[.] Preferences

=)

type filter text
> JavaEE
> Java Persistence
> JavaScript
> Maven
> Mylyn

> Oamph

> Remote Systems

[

Run/Debug
Breakpoints
Consale

> Launching
OpenOCD

Perspectives
QEMU

> Server

> Team

> Terminal
Walidation

> Web

> Web Services

> XKML

4 I

Yy =
@ @

> Plug-in Development

External Tools

Peripherals views

SEGGER J-Link
String Substitution
Target Communicat
TCR/IP Manitor
View Management
View Perfarmance

I

Perspectives

These settings contral perspectives for running and debugging. A perspective can automatically
open when launching or when an application suspends.

@ Always (0) Mever () Prompt

Open the associated perspective when launching

Open the associated perspective when an application suspends

() Always  (0) Mever @ Prompt

These settings assign perspectives to each application type or launcher and launch mode set. Select
"Mone” to indicate that a perspective should not be opened.

Application Types/Launchers:

IMades/Perspectives:

> G Java Applet
> [2] Java Application
> Ju JUnit
> Ju JUnit Plug-in Test
> I Launch Group
Local Praxy Application
> m2 Maven Build
. & 0SGi Framewark
> @, Program
> E Remate Java Application
> 9 Remote JavaScript
> R4 Rhino JavaScript

> Juy Task Context Test
- |/ TRACE32TCF
> ¢ XSL

4 I 2

- v w

> [ﬁ Target Communication Framewo |~

’Restore Defaults] ’ Apply ]

| [ cancel |
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TRACE32 View

In addition to the TCF communication, it is possible to control TRACE32 PowerView via a second UDP/IP
channel using the Remote API. The TRACE32 View [A] can be used for this purpose. To open this view go
to Window > Show View > Others > Debug > TRACE32. The command line [B] can be used to execute

TRACE32 and PRACTICE commands similar to the TRACE32 command line. TRACE32 PowerView

messages are then printed in the AREA field [C]. A TRACE32 menu is additionally added to the Eclipse

menu bar and contains shortcuts for special TRACE32 commands.

If TRACES2 is started from the TRACE32 Tab with an API port specified and the TRACES32 View is open, it
will connect automatically. You can also connect to TRACE32 using the Connect button [D].

= eclipse-workspace - C\T32\dema’arm' compiler gnu'sre' siev = EI@
File Edit Source Refactor MNavigate Search Project Ri|v [ TRACE32 | Window Help
Tu ks i @®-iBiw| b T Run Script -0~ Q-i®e F-il -Gl oD
B Edit Script 0 fck Access o | <Plug-in Development > @ & Plug-in Development
RFE In Target Reset i
45 Debug &3 le] 9 Breakpoints 7 Registers = B8
A © SY¥Stem.Mode Down - ‘
4 Mew_configuration (TRACE32 PowerView for ARM 0 [SIM J1 1] {‘p s, <§|) -
a B ARMO22T (Suspended; Signal: stopped at breakpoint) @ SRR
= 0000 126¢ [sieve] main{): ..ema’arm'compilergif s ©  s¥Stem.Maode Up
= 0l000043¢ [sieve] gomaini): ...ema'arm\compiler | jn 3 SY¥Stem.Made Go
B WEPER
' sieve.c 52 = B 5= Outline % = B
679 woid (*monHook){woid) _ attribute_ ((section (".data™))) = @; - = iaz & o % -
int main(void) @ func_sinfvoid) : vaid -
{ ) ® init_linked_list{void) : vaicl
int i & shortrecord
short int  inc, sign; ® vshortrecord : struct shortrecord
char ps @ func2i{struct shartrecard) : struc
func_sin(); U {anonymous)
N - ® datas : union -
El Console J=| Tasks TCF Trace Memo! TRACE32 2 - A 5 = 8
Lo Y
Connected to TRACE32 via |06 g 10000
TRACE32 Command
AREA
4 b
o

©1989-2024 Lauterbach

TRACES32 as TCF Agent

31



Troubleshooting

TRACE32

TCF=(illegal command)

If you get this error message when starting TRACE32, then your TRACES32 version is too old and does not
support TCF. You should use a TRACE32 version from February 2016 or newer.

. To check your TRACE32 version, choose Help menu > About TRACE32.

Eclipse

No TRACE32 PowerView instance under “Available Targets”

Please make sure that TRACE32 PowerView has been started as TCF agent with enabled TCF discovery.
1. To check this, select the TRACE32 Help menu > About TRACE32.
Under Environment, you can see the used configuration file.

2. Click edit and check if the configuration file contains the TCF block.

If the TCF discovery has been disabled by using a fixed port number in the configuration file, the target setup
needs to be done manually. Moreover, you can use the PRACTICE function TCF.PORT() in TRACE32 to
print the used port number (requires TRACE32 build 71550 or newer):

PRINT TCF.PORT ()

Cannot locate peer TCP:<ip>:<port>

Please check that TRACE32 PowerView has been started as TCF agent and that you are using the correct
port number in Eclipse.
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Help Us to Help You

Export the TRACE32 System Information

Be sure to include detailed system information about your TRACE32 configuration.

1. To generate a system information report, choose TRACE32 > Help > Support > Systeminfo.
Lauterbach Homepage
Support > & System Information...

N About TRACE32 2 Update TRACE32...

B Technical Support Contacts

4 Contact Lauterbach .

P Generate TRACE32 Support Information E@.
Press the following button to get help on how to generate Support Information:
Company: Lauterbach Department: |
Prefix:

Firstname: Andrea

Surname: Martin

Street: Altlaufstr, 40 P.O.Box:

City: Hoehenkirchen-Siegertsbr. ZIP Code: 85635

Country: Germany

Telephone: (+49) 8102-9876-355

eMail: andrea.martin@lauterbach.com |
Product: PowerTrace PX |

Target CPU: ARMSA0T

Hostsystern: | Windows 10 v
Compiler: Arm
Realtime0S: | Mono Safe Mode: [
Generate Support Information: Save to Clipboard | | Save to File
NOTE: Please help to speed up processing of your support request. By filling out the

system information form completely and with correct data, you minimize the
number of additional questions and clarification request e-mails we need to
resolve your problem.

2. Preferred: click Save to File, and send the system information as an attachment to your e-mail.

3. Click Save to Clipboard, and then paste the system information into your e-mail.

Export the Eclipse Error Log

Please include the full Eclipse Error Log as a file in your support request:
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1. Choose Window menu > Show View > Error Log to open the Error Log view in Eclipse.
On the Error Log view tool bar, click the Export icon.

Save the log as a file.

P 0D

Attach this file to your support request.

Export the Eclipse Configuration

Export the Eclipse configuration settings in text form to the clipboard. With this we can check your Eclipse
configuration for any missing or outdated components.

1. Choose Help menu > About Eclipse.
2 Click the button Installation Details.
3 Click the Configuration tab.

4. Click Copy to Clipboard.
5

Paste the clipboard content into your support mail to Lauterbach.
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TCF Commands

SYStem.TCFconfig TCF-specific setups

The SYStem.TCFconfig command group is used to define TCF-specific setups for debugging.

See also
B SYStem.state

SYStem.TCFconfig. TASKCONTEXT Enable/disable task contexts
Format: SYStem.TCFconfig. TASKCONTEXT [ON | OFF]
Default: ON.
ON Operating system tasks are displayed in the Eclipse debug view as child
contexts.
OFF Operating system tasks are not displayed in the Eclipse debug view as

contexts. Only the name of the current task is displayed for information.
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