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Debugger Tutorial

Version 06-Jun-2024

History

05-Jun-2024 Revised manual

About the Tutorial

This tutorial guides you through the necessary steps to configure and start a debug session using a 
TRACE32 hardware-assisted debugger. It also demonstrates basic debug functionality using the TRACE32 
PowerView interface, helping you become familiar with the fundamental features of TRACE32

This is an entry-level document intended for users with little or no prior experience with TRACE32 debug 
tools. For a detailed overview of all debug features, refer to “Training Basic Debugging” 
(training_debugger.pdf).

To follow this tutorial, a basic understanding of software debugging and the C-programming language is 
helpful, as it will allow you to follow the example code provided. Additionally, a basic knowledge of the target 
processor and the assembler/compiler used is necessary to get your debug system running.

This tutorial assumes that the TRACE32 debugger software is already installed. You can do so install the 
TRACE32 software from the DVD included with the tools. Alternatively, you can download the TRACE32 
software installation package can also be downloaded from the Lauterbach website. The Installation 
process is outlined in “Software Installation”  in TRACE32 Installation Guide, page 20 (installation.pdf).
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Connect the TRACE32 Hardware

To proceed with this tutorial, a functioning target platform is needed, such as a development board. 

Follow then these steps:

• If the debug probe is already connected to the target, disconnect it while the target power is off. 

• Connect the TRACE32 hardware according to the instructions provided in “Tool Configuration”  
in TRACE32 Installation Guide, page 9 (installation.pdf). 

• Power on the TRACE32 hardware

• Proceed with the next chapter of this tutorial

Start TRACE32 PowerView

The TRACE32 executables are named t32m<architecture>[.exe] and are located in the bin\<os> 
directory within TRACE32 installation directory
(e.g. bin\windows64 or bin/pc_linux64).

These executables launch the TRACE32 graphical user interface, known as TRACE32 PowerView. Each 
executable is specific to a target processor architecture; for example, t32marm starts TRACE32 PowerView 
for Arm, while t32mtc starts it for TriCore. The executables available in the bin\<os> folder are 
determined by the target processor architectures selected during the installation process. 

You can start TRACE32 PowerView by either double-clicking the t32m<architecture> executable or 
running it from the command line without any additional parameters.

Example for Windows:

Example for Linux:

C:\T32\bin\windows64\t32marm.exe

/opt/t32/bin/pc_linux64/t32marm
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TRACE32 PowerView will initiate an “interactive connection mode”, enabling users to select the desired 
operation mode through user interface: 

Please follow the “Connection Widzard” and enure that the TRACE32 debugger module being used is 
powered on and connected to the host PC via USB or Ethernet.

If the connection to the TRACE32 debugger hardware is successfully established, the TRACE32 PowerView 
interface starts. By default, a “Welcome to TRACE32!” dialog appears. This dialog displays the target 
architecture and used TRACE32 debug module. It and includes links to key manuals.

NOTE: Before TRACE32 Release R.2024.09, a configuration file was by default used 
to define the TRACE32 operation mode and various other TRACE32 settings. 
However, this tutorial will not delve into the configuration file. For further details, 
please refer to the “TRACE32 Installation Guide” (installation.pdf).
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The status line will display a red “power down” status, indicating that no reference voltage has been detected 
at the VCC pin of the debug probe. This is normal, since the debug probe is not yet connected to a powered 
target board.

Connect now the debug probe to your target platform then power on the target. The status line will indicate a 
grey “system down” status.
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Set Up the Debug Environment

We can proceed now with the necessary steps to establish a debug connection with the target processor. 
The start-up procedure for the debug session depends significantly on the processor used. 

To simplify the start-up procedure for TRACE32 users, the demo directory within the TRACE32 installation 
folder includes a comprehensive collection of ready-to-run PRACTICE scripts. These scripts contain the 
necessary configurations to establish a debug connection with a wide variety of publicly available target 
chips and boards.

You can search for a suitable script for your target platform using the “Search scripts...” view, which can be 
accessed by clicking the Start with examples button in the Welcome to TRACE32! dialog. Additionally, you 
can open the “Search scripts...” view from the TRACE32 PowerView menu by selecting “File” > “Seach 
for Script”. 

You can also inspect the demo directory manually from the TRACE32 installation directory.

NOTE: For detailed information on CPU-specific settings, refer to the Processor 
Architecture Manual, which can be accessed by selecting Help > Processor 
Architecture Manual from the TRACE32 PowerView menu.
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A Typical Setup Procedure

This chapter outlines a typical setup procedure for the debugger. To demonstrate the necessary steps, we 
will start with a manual setup. Later, we will show you how to use PRACTICE scripts (*.cmm) to automate 
this process. For simplicity, we will use here a single-core system as an example. 

The SYStem Window offers access to all CPU-specific settings. You can access this window by selecting 
the “CPU” and then choosing “SYStem Settings...”

CPU Selection

The initial step is to inform the TRACE32 debugger about the specific core/chip on your target [A, B]. A 
manual selection is not necessary if the target processor architecture supports automatic detection using the 
command SYStem.DETECT CPU. However, it's worth noting that this automatic detection is not always 
supported, such as in the case of Arm processors. 

Examples:

Adjust the JTAG Clock

The debugger uses a default JTAG clock of 10 MHz [F]. This frequency impacts the download speed. You 
may need to reduce the JTAG frequency if there are buffers, additional loads, high capacities on the JTAG 
lines, or if VTREF is very low. 

SYStem.DETECT CPU Auto detection of CPU

SYStem.CPU <cpu> Select the CPU/chip

SYStem.CPU CortexR5

SYStem.CPU CortexR5* ; Wild card symbols allowed

SYStem.JtagClock <frequency> Select the JTAG clock

B

C

D

E

F

A
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Examples:

Establish Debug Communication

Establish communication between the debugger and the core. The most common method is to select the Up 
mode [D].

When Up is selected, the following steps are per default performed:

• The core is reset.

• Communication between the debugger and the core is initialized.

• The core is stopped at the reset vector, if supported by the core in use.

Another useful method to establish the communication between the debugger and the core is Attach [E]. 
Attach allows the debugger to connect to an already running core. The Break.direct command can then be 
used to stop the target processor’s execution.

If you get an error after selecting Up or Attach, refer to the Processor Architecture Manual. 

SYStem.Option Commands

Please note that some cores require additional settings using SYStem.Option commands, for example 
related to reset handling, before communication can be established. Most relevant options can be 
configured from the SYStem window. The available SYStem.Option commands depend on the target 
processor architecture. A description of all available options can be found in the Processor Architecture 
Manual.

In case you need assistance, please refer to the chapter “Contacting the Lauterbach Support”, page 40.

SYStem.JtagClock 1MHz ; Reduce the JTAG clock to 1MHz on 
; a slow target 

SYStem.JtagClock 20MHz CTCK ; Use compensation clock with
; an Arm debug cable 

SYStem.Up Establish the communication between the debugger and the core

SYStem.Mode Attach Establish the communication between the debugger and the target 
core (without reset)

Break.direct Stop program execution
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Additional Settings

In some cases, additional settings using Data.Set commands are necessary after establishing the debug 
connection. For example, you man need to disable a watchdog or initilize the target RAM.

Example: command sequence to disable a watchdog. The specific sequence will vary depending on the 
target processor used.

For more information, please refer to the TRACE32 demo scripts and the documentation of your target 
processor.

Load Application

Setting up a debug environment involves loading the code to be debugged and the associated debug 
symbols. TRACE32 PowerView supports a wide range of compilers and compiler output formats. You can 
find a list of supported compilers on the Lauterbach website.

The most important commands for loading the code to be debugged and the associated debug symbols is 
Data.LOAD. Per default, the command loads the code/data from the specified file into the target memory 
and loads the symbol and debug information into TRACE32 PowerView. Using the option /NoCODE only the 
debug symbols are loaded. 

<sub_cmd> defines the file format, for example Elf. If you omit the format, TRACE32 PowerView tries to do 
an auto-detection.

The necessary steps for loading the application vary depending on whether the application is intended to run 
from RAM or flash memory.

Application Located in RAM

If the application is intended to run from RAM, you can directly use the Data.LOAD command. Just type 
Data.LOAD.* then select the file you want to download. 

Data.Set <address>|<range> [%<format>] <string> Modify memory-mapped 
configuration register/on-chip 
peripheral

; disable the Watchdog
Data.Set AD:0x40011C00 %Long 0x1ACCE551
Data.Set AD:0x40011C00 %Long 0xE5331AAE
Data.Set AD:0x40011008 %Byte 0x0

Data.LOAD.<sub_cmd> <file>    /<option> Load code and debug symbols

Data.LOAD.<sub_cmd> <file> /NoCODE    /<option> Load only debug symbols
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Examples:

Application Located in Flash

TRACE32 supports programming on-chip and off-chip NOR flash memories, as well as serial flash 
memories, such as NAND, SPI and eMMC. However, For simplicity, this tutorial will focus on on-chip flash 
programming. 

Ready-to-run scripts for most on-chip flash memories can be found in the TRACE32 installation under 
~~/demo/<architecture>/flash/<cpu>.cmm

Examples:

To program your application to the on-chip flash memory of your processor/chip, follow these steps:

1. Call the flash programming script appropriate to your processor/chip.

2. The script will perform all necessary preparations then displays a pop-up asking the user to 
confirm proceeding with the flash programming.

3. A file dialog is then opened, allowing you to browse the target application you want to program.

If the application is compiled with debug symbols they are automatically loaded into TRACE32 PowerView 
along with the flash programming.

The following framework can be used to call the flash programming script from your start-up script 

Data.LOAD.Elf demo_sram.elf ; Load code and debug symbols from
; Elf file 

Data.LOAD.Elf * ; Load code and debug symbols from
; ELF file 
; open file browser to select file

~~/demo/arm/flash/stm32h7.cmm

~~/demo/tricore/flash/tc37x.cmm

CD.DO ~~/demo/tricore/flash/tc37x.cmm PREPAREONLY
FLASH.ReProgram ALL
Data.LOAD.Elf myapplication.elf
FLASH.ReProgram off
SYStem.Up
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A video tutorial on programming the processor’s internal flash memory using TRACE32 is available 
here:
support.lauterbach.com/kb/articles/flash-programming

Further Documents:

• For on-chip and off-chip NOR, as well as memory-mapped serial flash programming, refer to the 
“Onchip/NOR FLASH Programming User’s Guide” (norflash.pdf).

• For non-memory-mapped flash programming, such as NAND, SPI and eMMC, refer to “NAND 
FLASH Programming User’s Guide” (nandflash.pdf), “Serial FLASH Programming User’s 
Guide” (serialflash.pdf) or “eMMC FLASH Programming User’s Guide” (emmcflash.pdf).
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Start-Up Scripts

It is strongly recommended to summarize the commands used to set up the debug environment in a start-up 
script. For this purpose, the script language PRACTICE is provided. 

The standard extension for a script file is .cmm.

Write a Start-Up Script

The debugger provides an PRACTICE script editor, that allows to write, to run and to debug a start-up script. 
The editor window provides syntax highlighting, configurable auto-indentation as well as multiple undo and 
redo.

The debugger provides two commands, that allow you to convert debugger configuration information to a 
script.

PEDIT <file> Open <file> with the script editor

PEDIT my_startup.cmm

STOre <file> [<item>] Generate a script that allows to reproduce the current settings

ClipSTOre [<item>] Generate a command list in the clip-text that allows to reproduce the 
current settings

STOre system_settings.cmm SYStem

PEDIT system_settings.cmm

; Generate a script that allows you
; to reproduce the settings of the
; SYStem window at any time

; Open the file system_settings.cmm

ClipSTOre SYStem ; Generate a command list that
; allows you to reproduce the
; settings of the SYStem window
; at any time
; The generated command list can be 
; pasted in any editor
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Run a Start-up Script

You can run a PRACTICE script from the TRACE32 PowerView interface by selecting the menu “File” > 
“Run Script...”. This action corresponds to using the TRACE32 command DO with the script name as 
parameter.

Example:

Alternatively, you can select the “File” > “ChangeDir and Run Script...”. The difference here is that 
TRACE32 PowerView will change the current working directory to the directory of the selected file before 
running the script.

Example:

Automated Start-up Scripts

When a TRACE32 instance starts, the PRACTICE script autostart.cmm is executed, which then calls the 
following scripts:

• system-settings.cmm (from the TRACE32 system directory, usually C:\T32)

• user-settings.cmm (from the user settings directory: on Windows %APPDATA%\TRACE32 or 
~/.trace32 otherwise)

• work-settings.cmm (from the current working directory)

With the command line option -s <startup_script> you can specify an additional PRACTICE script (*.cmm) 
which is automatically started afterwards.

Example:

DO <file> run PRACTICE script

DO my_startup.cmm

ChDir.DO <file> Change directory and run script

ChDir.DO C:\my_scipts\my_startup.cmm

C:\T32\t32arm.exe -s C:\my_scripts\start.cmm
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User Interface - TRACE32 PowerView

The graphical user interface (GUI) of TRACE32 is called TRACE32 PowerView.

The following screenshot presents the main components of this interface.

 We’ll briefly explain the GUI using the List command and List window as an example. For a more 
comprehensive introduction, a video tutorial about the TRACE32 PowerView GUI is available here:
support.lauterbach.com/kb/articles/introduction-to-trace32-gui

To open the List window, do one of the following:

• Choose View > List Source from the menu

• At the TRACE32 command line, type: List (or L)

Main Menu Bar
Main Tool Bar

C
o

n
te

xt
 M

en
u

 

Local Buttons

Message Line
SoftkeyLine
State Line

Window Area

Command Line
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The List window displays the code in both assembler mnemonic and HLL (High-Level Language). HLL 
refers to the programming language of your source code, e.g. C or C++.

In the List window, the gray bar indicates the position of the program counter (PC). In the screenshot above, 
it is located at the symbolic address of the label main.

A video tutorial about the source code display in TRACE32 is available here:
support.lauterbach.com/kb/articles/displaying-the-source-code

To summarize, you can execute commands in TRACE32 PowerView using the following methods:

1. Menus on the menu bar

2. Buttons on the main toolbar and the buttons on the toolbars of TRACE32 windows

3. Context menus in TRACE32 windows

4. Using commands via the TRACE32 command line.

Opens the 
List window

Program 
counter (PC)
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TRACE32 Command Line and Softkeys

TRACE32 commands are not case sensitive:  register.view is the same as Register.view

• UPPER CASE letters indicate the short forms of commands and must not be omitted. 

• All lower case letters can be omitted. 

This makes short forms an efficient time saver when entering frequently-used commands in the command 
line. 

Examples:

• Instead of the long form Register.view type just the short form r or R

• Instead of the long form List type just the short form l or L

The softkeys are located below the command line. The camel casing (i.e. upper and lower case letters) on 
any softkey indicates the long form of a command. The softkeys guide you through the command input, 
displaying all possible commands and parameters.

Example - To assemble the Data.dump command using the softkeys:

1. Click Data.

2. Click dump.

3. Type the <range> or <address> you want to dump. For example, 0x1000--0x2000

4. Click [ok] to execute the command. 

The Data.dump window will open.

Softkeys

Command line
Debugger Tutorial     |    18©1989-2024   Lauterbach                                                        



Window Captions - What Makes Them Special in TRACE32?

The command used to open a window is displayed in the window caption, along with any parameters and 
options used.

You can re-insert a command from a window caption (a) into the command line (b) in order to modify 
the command. Let’s do this with the Register window.

1. Choose View > Register from the menu. 

2. Right-click the window caption (a).

3. Modify the command, e.g. by adding the /SpotLight option: This will highlight changed registers.

4. Click [ok] to execute the modified command.

5. Click  Single Step on the TRACE32 toolbar. Changed registers are highlighted immediately.

(a)

(b)
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Debugging the Program

Basic Debug Commands

The basic debug commands are accessible from:

• the Run menu

• the toolbar of the List window

• the main toolbar 

• the TRACE32 command line.

 Single stepping  is one of these fundamental debug commands. 

Step over function calls or subroutines

Go to the next code line written in the program listing

Go Return / Go to the last instruction of the current function

Useful e.g. to leave loops

Single Step

        Stop the program execution

Go / Start program execution

Go Up / return to the caller function

Step till next unreached line
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TRACE32 PowerView also offers more complex debug control commands. For example, you can step until 
an expression changes or becomes true. 

Example: 

Debug Modes

Take a look at the state line at the bottom of the TRACE32 PowerView main window:

 

Var.Step.Till i>11. ; single-steps the program until the 
; variable i becomes greater than 11. 
; Please note that TRACE32 uses a dot to 
; denote decimal numbers. 

The state line provides the following information

A The (symbolic) address of the current cursor position.
The program counter (PC) is highlighted in gray.

B The state of the debugger: stopped indicates that the program execution is stopped. At this 
point, you can inspect or modify memory, for example.

C The state line displays the currently selected debug mode, which can be: 

• HLL (High Level Language)

• ASM (assembler)

• MIXed mode showing both HLL and its corresponding assembler mnemonic. 

A B C
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1. On the toolbar of the List window, click  Mode to toggle the debug mode to HLL.

2. Click  Step. 
In HLL mode, this action moves the program execution to the next source code line.

3. Click  Mode again to toggle the debug mode to MIX.

4. Click  Step. 
This time, the step executes one assembler instruction.

5. Right-click a code line, then select Go Till. 
Program execution starts, and stops when the program reaches the selected code line.

  

Debug mode HLL Debug mode MIX
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Displaying the Stack Frame

For the next example, we will assume that we have the following call hierarchy: main() calls func2() and 
func2() calls func1():

Select Show Stack in the Var menu. This will open the Frame.view window, displaying the call hierarchy. 

The /Locals option displays the local variables of each function, while the /Caller option shows a few source 
code lines to indicate where the function was called. 

This screenshot corresponds to the calling hierarchy described above.
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Breakpoints

Video tutorials about breakpoints in TRACE32 PowerView are available here:
support.lauterbach.com/kb/articles/using-breakpoints-in-trace32

Setting Breakpoints

Let’s set a breakpoint at the instruction prime = i + i + 3 and the instruction k += prime

To set a program breakpoint, double-click a code line where you want to set the breakpoint. Ensure to click 
the white space in the code line, and not the code literal. All code lines with a program breakpoint are 
marked with a red vertical bar.

To set a breakpoint to an instruction that is not in the focus of the current source listing:

1. Choose Var > Show Function from the menu.
The sYmbol.Browse.Function window opens.

2. Select the function you are interested in, for example sieve. 
The List window will open, displaying this function. This window is now fixed to the start address 
of the function sieve and does not move with the program counter cursor. 
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Setting Read/Write Breakpoints

You can set a breakpoint that halts the program execution at a read or write access to a memory location, 
such as global variable. 

To set a breakpoint on the array flags, for instance, right-click on the array name in the List window then 
select Breakpoints > Write.
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Listing all Breakpoints

1. Choose Break > List from the menu to list all breakpoints. 
The Break.List window opens, providing an overview of the set breakpoints.    

2. On the toolbar, click  Go to start the program execution. 

3. When the program execution stops at a breakpoint, it is highlighted in the Break.List window.

A Address of the breakpoint.

B Breakpoint type, for example Program, Read, Write

C Breakpoint method: SOFTware, ONCHIP or DISABLED. 

D Symbolic address of the breakpoint. Example:
• sieve\11 means source code line 11 in function sieve. 

A B C D
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Variables

Video tutorials about variable display in TRACE32 are available here:
support.lauterbach.com/kb/articles/variable-logging-and-monitoring-in-trace32

Displaying Variables

Let’s display the variables flags, def, and ast.

1. Choose Var > Watch... from the menu.
The Var.AddWatch window will open, displaying the variables known to the symbol database.

2. Double-click the variable flags.
The Var.Watch window will open, displaying the selected variable.

3. Alternative steps: 

- In the Var.Watch window, click  Watch, and then double-click the variables def and 
ast to add them to the Var.Watch window.

- From a List window, drag and drop any variable you want into the Var.Watch window.

- In a List window, right-click any variable, and then select Add to Watch window from the 
context menu.
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- If you want to display a more complex structure or an array in a separate window, 
select the menu Var > View.

Displaying Variables of the Current Program Context

1. Set the program counter (PC) to the function sieve() by typing the following at the TRACE32 
command line: 

2. Select the menu Var > Show Current Vars.
The Var.REF window opens, displaying all variables accessed by the current program context.

3. Click  Step on the TRACE32 PowerView toolbar to execute a few single steps. 
The Var.REF window is updated automatically.

Using the Symbol Browser

The symbol browser offers an overview of the variables, functions, and modules currently stored in the 
symbol database.

1. Select Var from the menu, then choose Watch...
The Var.AddWatch window will open, allowing you to browse through the contents of the symbol 
database. Global variables are displayed in black and functions in gray. Double-clicking a function 
will display its local variables are displayed.

2. In the Var.AddWatch window, double-click func2.

Register.Set PC sieve 
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Formatting Variables

To format the display of variables with global settings:

1. Choose Var from the menu, then select Format.

2. In the SETUP.Var window, configure your settings. TRACE32 applies your settings to all Var.view 
windows that you open afterwards. 

To format the display of an individual variable:

1. At the command line, type: Var.view ast  (The variable ast is included in this demo.)

2. In the Var.view window, right-click ast, and then click Format.
The Change Variable Format dialog opens.

3. Select the Type check box to display the variable ast with the complete type information.

4. Click Apply. The format of ast in the Var.view window is updated immediately.
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5. For more complex variable select TREE in the Change Variable Format dialog box. 

Modifying Variables

1. Double-click the variable value to modify the value. The Var.set command will be displayed in the 
command line. The short form of the command is V or v

2. Enter the new value directly after the equal sign and confirm with [ok].

Click + and - to expand 
and collapse the tree.
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Memory

Displaying Memory

1. To display a memory dump in a Data.dump window, do one of the following:

- Choose View from the menu then select Dump,

- Click  Memory Dump on the toolbar,

- Type: Data.dump in the TRACE32 command line. You can also specify an address or 
symbol directly, e.g.: Data.dump flags  

2. In the Data.dump dialog, enter the data item, e.g. flags

- Alternatively click  to browse through the symbol database. 

3. In the Browse Symbols window, double-click the symbol flags to select it, and then click OK.

Double-click flags.
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In the following screenshot, the Data.dump window is called via the TRACE32 command line. 

There are different ways to define an address range:

• <start_address>--<end_address> (SD is an access class)

• <start_address>++<offset>  

Modifying Memory

1. In a Data.dump window, double-click the value you want to modify. 
A Data.Set command for the selected address is displayed in the command line. The short form 
of the command is D.S or d.s

2. Enter the new value directly after %LE, and then confirm with [ok]. 
(%LE stands for Little Endian).

Data.dump SD:0x5530--SD:0x554F

Data.dump cstr1++0x1f /Byte ;start at cstr1 plus the next 0x1f bytes

Access Class + Address HEX ASCII 
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Peripheral View

TRACE32 supports a freely configurable window for displaying and manipulating configuration registers and 
on-chip peripheral registers at a logical level. Predefined peripheral files are available for most standard 
processors/chips.

You can open the peripheral register view in the TRACE32 by selection the CPU menu, then Peripherals, or 
by using the command PER.view in the TRACE32 command line.

PER.view Display peripheral registers
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Store Window Configuration

To save the window configuration for you next debug session use Store Windows… from the Window 
menu. This action generates a PRACTICE file that includes all commands to reactivate your complete 
window configuration automatically. 

The saved window layout can be loaded again for the next debug session with the Load Windows… from 
the Window menu.

You can also add a call into your start-up file:

DO win_layout.cmm
Debugger Tutorial     |    34©1989-2024   Lauterbach                                                        



Getting Online Help

The online help system consists of several documents. They are accessible as PDF-files directly from the 
TRACE32 software and can be found in the pdf directory. 

There are different ways to open the TRACE32 online help:

• Help Topics button on the toolbar

• Help menu > Contents

• HELP command in the command line

• Help button in the Welcome to TRACE32! dialog.
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The help system is organized in a multilevel structured way. The screen below shows how to find this tutorial.
 

It is also possible to help for a single command. Enter the command into the command line, add a space and 
push F1.
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Contacting the Lauterbach Support 

If you need assistance in setting up the debugging environment, be sure to include detailed system 
information. 

1. To generate a system information report, choose Help > Support > Systeminformation …

2. Fill in the form then click Save to File, 

3. Send the system information as an attachment to support@lauterbach.com together with the 
problem description.
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